Tried to log onto the game after the maintenance update, and had no problem at first. I clicked one of my barracks to train troops but when I hit the Train button nothing happened. I tried several more times to no avail.

I restarted my device thinking this would clear up the issue (it usually does on the rare occasion there's a problem) and the game started to load, showing the Kabam logo and then the loading screen. Almost immediately I got a Fatal Error message, hit OK on it, and it started over. This time the load bar got to about 50% and had the Loading Assets message underneath, but wouldn't progress. I put my phone down for a half hour to give it time to load, but when I checked it was in the exact same spot, no progress and can't get the game to open.

Strange thing is it seems to be running normal in the background, since I got a pop up message on my phone that my Battering Rams training had completed.

I doubt it's a coincidence this happened immediately following an update. My gamer name is DIrishB, please let me know what's going on.

Should I delete the app and redownload it? Will this erase all my progress (doubt it since I have my Kabam ID, but just want to be sure before doing it).