Results 1 to 5 of 5

Thread: Bug loading battleground

  1. #1

    Unhappy Bug loading battleground

    Hi,
    When i want to play battlegound event, i come 2 minutes before it starts it tells me it's not open yet or the loading bar appears but never ends.
    I know i'm not the only one to have this bug on the server (108 GMT).
    It's really annoying, we're limited on the honor and insignia gains.
    Hope you will do something about that really fast thanks in advance

  2. #2

    Same issues

    I'm experiencing the same, please fix it

  3. #3
    Moderator Veteran Guardian
    Join Date
    Sep 2016
    Posts
    125
    Quote Originally Posted by Anaida View Post
    I'm experiencing the same, please fix it
    The issue has been reported and should be fixed now, if after refreshing the game the issue is still ongoing, please write to Customer Support with screey or a brief video (if you can) and describing the issue in detail. Email: wtm@gaea.zendesk.com

    All the best!
    Ceridwen
    (forum moderator)
    Discord ID: Ceridwen#5518 (if my forum inbox is full)



    *Moderators are not Gaea staff or employees, they do not have access to player accounts or other personal details. They are players like you, who have volunteered to help other players with game issues and/or to help facilitate communication between Gaea and all players

  4. #4

    Bg

    I still have the same issue. I sent a ticket

  5. #5
    Moderator Veteran Guardian
    Join Date
    Sep 2016
    Posts
    125
    Quote Originally Posted by Keldastar View Post
    I still have the same issue. I sent a ticket
    you did well - please let us know how you go ! All the best
    Ceri

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •