Results 1 to 3 of 3

Thread: Sylph upgrade (advanced mahra) bugged

  1. #1

    Sylph upgrade (advanced mahra) bugged

    Today a guildmate reported a problem with advanced sylph upgrade. The event worked fine yesterday, today I tried with 10 adv mahra and the screen says I already claimed my reward, which I didn't.
    I'm going to send a ticket , but wanted to let ppl know, before they waste their adv mahra for nothing.
    Kilme2015 server 42 eu

  2. #2
    Junior Member Junior Guardian
    Join Date
    Mar 2016
    Posts
    20

    Advanced slyph mahras upgrade not giving rewards

    Same issue. It was working yesterday.
    Today I spent 1000 advanced mahras, screen says claimed but actually got nothing.

  3. #3
    Wow thought this event would be awesome since we finally got one for advanced mahra! Nope broken also server 64 never got the magic pot no support staff will read this so F it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •